Titanic Inquiry Website


Aug 13, 2006
2
0
71
Hi. Can anyone else get into the www.titanicinquiry.org website as I keep getting a Page cannot be Displayed? Is there a problem with the website? I have been able to access it but for the last couple of days it seems to have a problem. I was halfway reading through the Senate Inquiry, now Im stumped! Hope it hasn;t been taken off the web as I was really into the whole Inquiry! Hope anyone can shed any light on this, or let the webmaster know.

Thanks for your time

Stewart (UK)
 

Rob Ottmers

Member
Feb 8, 2001
82
1
146
Hello Stewart,

Apologies for the site being down. It's having server difficulties which are being addressed. Hopefully it wont be long. We're also working on a site rework - please stay tuned.
 
Aug 13, 2006
2
0
71
Hi Rob, Thank you so much for your reassurance. I look forward to it being back up and running again.

[Moderator's note: This post and the two above it, were originally posted in another subtopic, but have been moved to here. JDT]
 
Dec 2, 2000
58,614
692
483
Easley South Carolina
Just to give everybody a heads up, but Rob Ottmers and the team which has been working on the Titanic Inquiry Project Website have given the Titanic community a fine Christmas present this year. Along with a new look, they now have available a number of claims and depositions taken for the Limitation of Liability proceedings. This makes available a number of important documents on line for the first time.

The new domain is titanicinquiry.com

The Titanic Inquiry Project - Main Page domain remains in use.

My hat's off to all those who are involved in this work and the hours they've put in transcribing these documents for all to see!
 

Jason D. Tiller

Moderator
Member
Dec 3, 2000
8,243
24
308
Niagara Falls, Ontario
Thanks for the heads up, Mike. The new look is terrific and when the Limitation of Liability Hearings become available, they will be extremely valuable to anyone who is interested in reading them.

My hat is also off to all those involved. Well done!
 
Dec 2, 2000
58,614
692
483
Easley South Carolina
I'm glad somebody here finally noticed! Rob Ottmers and his team have done some truly incredible work. Some of the depositions from the Limitation of Liability are already there. I've had a hard copy of Edward Wilding's deposition for several years now, and it makes for some interesting reading. For us techies, it's an essential source.
 
M

Matt Pereira

Guest
Not to get off topic but does the " http://www.titanicinquiry.org/ " link work for anyone else? Ive been trying to get in to pull down some digital copies to my flash drive to review when I go to family reunion in a couple weeks but it just sits there and never gets past halfways on the page load bar at the bottom. Ive had it sit for about 2 hours now and it still isnt going past half ways even doing refreshing and even looked up online the site and clicked on a hard link and it does same thing in new browser window.
 
Dec 2, 2000
58,614
692
483
Easley South Carolina
I'm not having any problems with it, Matthew. Perhaps your rig has some compatibility issues.

[Moderator's note: This message and the one above it, initially posted to an unrelated thread (thus the "off topic" comment) have been moved to this pre-existing thread discussing the same web site. MAB]
 
M

Matt Pereira

Guest
Michael, I dont see why it would be, if it is this is the first time ive ever experianced this.

But if anyone has any ideas about how to rectify this I am all ears. I even tried to go to specific pages for both US and UK transcripts for specific people and it still doesnt want to load for me. Even tried .com instead of .org and no change.
 
Dec 2, 2000
58,614
692
483
Easley South Carolina
>>Michael, I dont see why it would be,<<

Lots of strange things happen in cyberspace for no apparant reason. For example, the post you're replying to isn't in this thread anymore. I didn't delete it and none of my colleagues had any reason to do so.

If some other disappearing posts are any indication, I'm not the only one this has happened to either. Some things simply defy explaination, but there's a problem somewhere.
 
M

Matt Pereira

Guest
Michael I agree cause I remember seeing your post. I just did a restart twice, first time didnt work because for some odd reason the laptop wouldnt get a wifi connection. Second restart it came right up. I put in the link again the bar moved quicker to the mid way point than before restart but it still stops at the 50% page loaded part with the previous page frozen.

Sucks because while I have a hardcopy book of the US inquiry I didnt see a hardcopy of the UK inquiry.

But I guess ill give it a day or two and see if it works might be something with the website itself. I already did all I could that could potentially cause the issue and its still there. Not to mention all other websites work its just that one that isnt.

I just had friend who also has IE8 to try the link and it comes up fine for them. So I cant say its the IE8 browser I have. I also did two restarts and no effect.
 
Dec 2, 2000
58,614
692
483
Easley South Carolina
What browser are you using? Whatever IE8's flaws, it performs for me. Some of the other browsers out there aren't quite what they're cracked up to be. Firefox is one that I hear a lot of people singing their praises to, but I've noticed it has a nasty tendency to forget your there or that you asked it to find something.

Not that IE8 doesn't do this on occasion, but it doesn't happen nearly as often.
 
M

Matt Pereira

Guest
Michael, im using Internet Explorer 8. While I have heard alot of issues exist with internet explorer I typically dont have problems. The Titanic Inquiry site is the first time ive runned into this situation. Last night I finally got it to load and I clicked on Day 1 of the US and it started not working again. What it appears to be doing is freezing up in the page itself but the tool bars are still useable.

I also tried the site again getting up I brought it up when I went to other room for a drink. I get back and it said "cant display the page" I though maybe it will work now so I hit refresh and now its doing that "freeze up" thing. you put the cursor on the bottom tool bar where the progress bar is and I get the vista "busy" cursor with the spinning circle like the browser froze up but the top portion of the browser isnt frozen. All I know is it is very weird.

[Moderator's note: The five messages after the last note have been moved for the same reason. MAB]
 

Similar threads

Similar threads